Java Platform Required

Java SE Runtime 7 or 8 for all systems except mobile

Supported Databases

It's easy to add new databases. Contact us if your database is not listed here.

  • Derby 10.x
  • DB2 9, 10, 11 (LUW, z/OS)
  • DB2 v5, 6, 7 (IBM i, iSeries, AS/400)
  • Firebird 2.x
  • Greenplum 4.x
  • H2 1.x
  • HSQLDB 1.8, 2.x
  • Ignite 2
  • Informix 11.5, 11.7, 12.1
  • Interbase XE, XE3, XE7, 2017
  • MariaDB 5.x, 10.x
  • MongoDB 2.x, 3.x
  • MySQL 5.02, 5.1, 5.5, 5.6, 5.7
  • NuoDB 2.x
  • Oracle 9i, 10g, 11g, 12c (EE, RAC, SE, XE)
  • PostgreSQL 8.2, 8.3, 8.4, 9.x
  • Redshift 1, 2
  • SQL Anywhere 9, 10, 11, 12, 16, 17
  • SQL Azure 11, 12
  • SQL Server 2000, 2003, 2005, 2008, 2010, 2012, 2014, 2016, 2017
  • SQLite 3.x
  • Sybase ASE 12.5, 15.x, 16
  • Tibero 6
  • VoltDB 5, 7
 

Supported Operating Systems

Any operating system that can run Java.

Linux x86 and x86-64

  • RedHat Enterprise Linux (RHEL), CentOS, Oracle Enterprise Linux - 5.x, 6.x, 7.x
  • SUSE Linux Enterprise Server (SLES) 11.x and OpenSUSE 11.x and 12.x
  • Debian GNU/Linux 6, 7, 8, 9
  • Ubuntu Linux 11.x, 12.x, 13.x, 14.x, 15.x, 16.x

Windows x86 and x86-64

  • Windows Server 2000, 2003, 2008, 2012, 2016
  • Windows 7, 8, 8.1, 10
  • Windows XP SP3

Unix

  • Solaris 9, 10, 11 SPARC; 10, 11 x86
  • IBM AIX 5.x, 6.x, 7.x
  • HP-UX 11i PA-RISC; 11i IA64

Mac OS X x86 and x86-64

  • Mac OS X 10.x

Mobile

  • Android 2.3, 3.2, 4.x, 5.x, 6.x, 7.x, 8.0
  • iOS 4, 5, 6, 7, 8, 9, 10, 11 (via REST)
  • Windows Mobile 5, 6.x (via REST)

Supported Application Servers

Deployment to an application server is optional.

  • Apache Tomcat 6, 7
  • JBoss 5, 6, 7
  • Jetty 7, 8, 9
  • WebLogic 11, 12
  • WebSphere 6, 7, 8

Supported Web Browsers

Deployment to an application server is optional.

  • Google Chrome
  • Mozilla Firefox
  • Microsoft Internet Explorer 10 and above
  • Apple Safari on Mac OS X
Need additional information?
Contact Us